SMS:File Menu

From XMS Wiki
Jump to navigationJump to search

The File menu is one of the standard menus available regardless of the current module and model. The File menu includes the following commands:

Open Open Macro.svg 
Used to read any file used by SMS. This includes a large selection of file formats, both generic and model specific. This command opens a file browser from which one or more files can be selected. SMS attempts to recognize the file type based on the file extension. The available file formats (extenstions) varies based on the module and model being used. For example, there are several types of *.dat file that are used by different models. If a selected file does not match the anticipated type, a message is given with the option to specify another format type to use when reading in the file. Data from the file is added to the current data base and SMS updates the display.
Import from Web... 
Opens the web services utility which allows for the automated download and import of certain data types from the internet.
Add Online Maps ... 
Brings up the Get Online Maps dialogue allowing selection of various online data. See Get Online Maps article for details.

Map Flood 
Tool for downloading flood level data.

Save Project Save Macro.svg 
Used to save an SMS Project File (file extension *.sms). The first time this command is invoked, prompt will ask for a file name (unless a project file has already been opened in SMS). Every other time, SMS saves the project file using either the file name used to save the project or the filename of a project opened in SMS. To save a project with a new name, the Save as... command is used. The SMS Project File is saved as an XMDF file. The contents of the SMS Project File can be viewed using a HDF5 file browser or editor.

Save <Model> 
The name of this command changes according to the active module and active model (i.e. Save RMA2 for the Mesh Module, RMA2 model). This command is similar to the Save Project command. The first time this command is invoked, prompt will ask for a file name (unless a project file has already been opened in SMS). Every other time, SMS saves the model file using either the file name used to save the model or the filename of a model opened in SMS. To save a model with a new name, the Save as... command is used.

Save as... 
Allows saving data currently in the SMS database in a format not associated with the current model nor SMS or to save a model or project file with a new name. Specify the Save as type in the Save dialog to select the file format. The Save as type available at any time depend on the data currently in SMS and on the current module and model (i.e. to save a map file, the map module must be active).

New 
Deletes all the data associated with all modules. It resets the status of the program so that all display option and default values match the values in the "settings" file. This command should be selected when a new modeling problem is started.
View Data File 
Since the process of numerical modeling often utilizes many input files and generates many output files, it is not uncommon to review an ASCII data file. When the View Data File command is selected, SMS asks to select a file. Based on the Preferences settings, the file will then open or SMS will ask which editor to open the file in by bring up the View Data File dialog. A separate process is created for editing/viewing the selected file using the selected editor. It should be remembered that this is now a separate process and the data in the file is not part of the SMS database. The data may be saved and incorporated into SMS using file read and import capabilities.
The View Data File dialog

Get Info 
Reports basic information concerning the data type associated with the active module. For example, for meshes, the Get Info dialog reports the number of nodes, the number of elements, the number of linear elements, etc. For more information, see Information Dialog.
Info Options  
Selection Information dialog
Brings up the Selection Information dialog. The Selection Information dialog allows turning on and off various data that can be displayed on the selected entities. The echo of the information to a file can be turned on and off with on Echo to File toggle. When this toggle is turned on, prompt will ask for a file name. The Display Echo Window option opens a window where information is also displayed.
See Echo Window for more information.
Save Settings 
Used to save the current settings of the program (display options, defaults, etc.) to a default settings file. SMS reads the "default settings" file each time it is launched or the new command is invoked.
Page Setup 
Used to set printing options. The dialog contains three tabs:

Margins

This page allows specifying up the margins that will be used for printing to the selected printer. The right side of the display shows a gray region representing how the graphics window would be positioned on a printed page.
The scale of the printed image directly depends on the margins that are set on this page. The margins have a lower limit depending on the system’s default printer.
The Maintain aspect ratio option should usually be checked. When this option is turned on, the size of the printed image be constrained by one pair of margins, either the top and bottom or the left and right.

Paper Size

This page allows defining the size of the paper for the selected printer. The specific available options are dependent on the system’s default printer. Both the paper size and paper source can be specified, as well as the image orientation on the paper.
The preview window shows a sample of what the printed image will look like.

Options

This page allows defining a scale to be added to the bottom of the printed image. If changing the scale value, the margins are updated to match. The scale is defined as either one inch or one centimeter, and will equal the specified number of units that the data is in. This could be feet, meters, lat/lon, etc. If, after the scale is set, zooming in or zooming out, the scale will change to match the new world boundaries and the page margins.
The preview window shows a sample of what the printed image will look like.
The data displayed in the Graphics Window is then printed through the Print menu item.
The Page Setup dialog showing the Margins tab.
The Page Setup dialog showing the Paper Size tab.
The Page Setup dialog showing the Options tab.

Print Print Icon.svg 
Opens the Windows Print dialog. Pages are printed with the data displayed in the Graphics Window using the settings set through the Page Setup menu command.
Demo Mode 
Since some users may not require all of the modules or model interfaces provided in SMS, modules and model interfaces can be licensed individually. The icons for the unlicensed modules or the menus for unlicensed model interfaces are dim and cannot be accessed. The Demo Mode command provides a way of evaluating additional modules to consider licensing in the future. This is particularly useful when using the tutorials provided with SMS.
When the Demo Mode command is selected, all modules of the program will be enabled. The only exceptions are that the Print and Save options will be disabled. It is important to note that when the mode is changed all current data will be deleted. When the program is in demo mode, a check mark appears next to the menu item. To return to normal operating mode, select the Demo Mode command again. If an evaluation copy of the software is being used, or if all modules are enabled, this menu item is unavailable.
Layout 
Launches the XMS Layout dialog for defining a print layout.
Recent Files 
SMS remembers the last five files opened during operation. These files are added to the File Menu. A file can be reopened by choosing it from the list.
Exit 
Used to exit the program. If the data has not been saved, SMS gives a warning before exiting.


Related Topics

SMS Menus