SMS:Mesh Data Menu

From XMS Wiki
Jump to navigationJump to search

Most of the SMS modules have a Data menu, but the items in this menu are different for each module. The Mesh Module commands include:

Command Description
Steering Module Model command – launches the steering dialog to connect multiple model runs.
Switch Current Model Model command – changes the current numerical model associated with the mesh.
Dataset Toolbox Opens the Data Toolbox containing various tools to work with datasets.
Map Elevation Dataset command – assigns a new "elevation" or "depth" dataset to the current mesh. See below.
Zonal Classification Dataset command – creates polygons matching user specified criterion from the current mesh and its datasets.
Vector Options Visualization command – invoke the vector options dialog (display options).
Contour Options Visualization command – invoke the contour options dialog (display options).
Set Contour Min/Max Sets the contour options based on the current options and the selected nodes/vertices or zoom level.
Contour Range Options Controls if the Set Contour Min/Max command applies to dataset specific contour options or the general contour options (for the mesh or scatter modules). It also sets the flags for precision and fill above and below.
Film loop Visualization command – launches the film loop generation wizard.
Mesh → Scatterpoint Data conversion command – converts the current mesh to a scatter point set. Also available as a right-click command. See Below.
Mesh → Map Data conversion command – converts the current mesh to a map module coverage. Also available as a right-click command. See Below.


Map Elevation

SMS requires that a mesh or grid have bathymetry, or bottom elevation data, associated with the nodes or cells. By default, SMS creates a dataset named "elevation" to store the elevation values. The dataset being used to store elevations is referred to as the mapped dataset.

The Data menus in several modules include a command to use another functional dataset as this mapped elevation function. When this command is performed the Select Dataset dialog opens to allow any existing scalar dataset to be chosen. Any time step of any scalar dataset can be used as the mapped dataset and override the previous nodal elevation values. This is used mainly when interpolating new elevation data from scatter points.

Mesh to Map

The convert Mesh → Map dialog

The Mesh → Map command in the Data menu (mesh module) is used to convert mesh data into feature data (map module). This can be useful for creating a conceptual model from an existing numeric model. The Mesh → Map command converts the mesh data and places it in the active coverage. This process makes use of the Mesh → Map dialog which provides conversion options. If wanting the new data in a new coverage, click on the Create New Coverage button to create a new coverage and make it active.

  • Material Regions → Polygons
This option converts the materials in the current mesh into polygons in the map module. If the coverage supports materials (area property or most mesh model coverages support this), the polygons will have attributes reflecting the correct material values.
  • Mesh Boundaries → Polygons
This option converts the current mesh boundaries into polygons in the map module.
  • Mesh Contours → Arcs
This option creates an arc at a specific contour value (based upon the active dataset). It is not necessary for the value to be associated with a displayed contour line as SMS will determine where the line would be if it existed.
  • Mesh Nodestrings → Arcs
This option creates an arc for each nodestring in the mesh.

Mesh to Scatterpoint

The Convert Mesh → Scatter Points dialog

The Mesh → Scatterpoint command in the Mesh Data menu is used to create scatter point data from existing mesh nodes. When this command is performed, the Convert Mesh to Scatter Points dialog appears to request a name for the new scatter point set.

When the scatter point set is created, it contains one scatter point for each mesh node, including midside nodes and center nodes. Any mesh datasets that have been read into SMS are copied into the new scatter point set. The scatter point data can then be used for interpolation.

Obsolete Commands

  • Create Datasets – Creates specific datasets for the mesh based on user specified options. No longer available as of SMS 10.1. Has been replaced with the Dataset Toolbox.

Related Topics