FEMWATER Flow Model Workflow

From XMS Wiki
Jump to navigationJump to search

This is a top level workflow. This workflow includes all of the specific workflows needed in creating a general FEMWATER flow model project using the conceptual model approach. Newer and infrequent GMS users should start here.

To build a FEMWATER flow model in GMS, use the following steps:

1. Start GMS.
1. Start GMS, or clear existing projects in GMS.
  1. If GMS is already running, select File | New.
  2. A new project can also be started by clicking New New Macro.svg.
2. If necessary, register or update GMS.
1. Register GMS and components.
  1. Launch the GMS Registration Wizard.
  2. Follow the Registration Wizard instructions.
  3. Review the registered components in the Aquaveo License Registration dialog.
2. Update GMS.
GMS can be updated by doing any of the following:
  1. Select Download if prompted to update when starting GMS.
  2. Select Help | Check For Updates.
  3. Go directly to the GMS download page.
3. Set the display projection.
  1. Select the Edit | Units... command.
  2. In the Units dialog, set the time, mass, force, and concentration.
  3. Click the Dot dot dot button.png button and set the horizontal and vertical projection in the Display Projection dialog.
  4. If necessary, use the Horizontal Projection dialog to set a global projection.
2. Import data.
1. Gather and open image files.

Images are imported into the GIS module in GMS.

1. Open local images.
  1. Load images from local computer files using the File | Open... command.
  2. Alternatively, drag and drop the file into the Graphics Window in GMS.
2. Import images from the web.
  1. Use the Add Online Maps Add Online Maps Icon.svg macro.
  2. Select a location in the Virtual Earth Map Locator.
  3. If a projection has not been set for the project, set a new project in the Display Projection dialog.
  4. Use the Data Service Options dialog to select a web service.
2. Gather and open geometric data files.
1. Import map data.
  1. Use the File | Open... command to import map data such as Map files, boundary ID files, or boundary XY files.
  2. Alternately, drag and drop the file into the Graphics Window in GMS.
2. Import GIS data.
  1. Use the File | Open... command to import GIS data files such as Shapefiles or raster files.
  2. Alternatively, drag and drop the file into the Graphics Window in GMS.
3. Import scatter data.
  1. Use File | Open... to open files with scatter data.
    • Alternatively, drag and drop the file into the Graphics Window in GMS.
  2. Use the File Import Wizard to specify how to import the data.
4. Import CAD data.
  1. Verify the CAD file type is readable by GMS before importing it. GMS can import DXF and DWG files.
  2. Use the File | Open... command to launch the Open dialog (or drag and drop) to import the CAD files.
The data should load in layers into the Project Explorer.
5. Review and set object projections.
  1. Right-click on an object in the Project Explorer and select the Projection | Projection command.
  2. Set the horizontal and vertical projection using the Object Projection dialog.
  3. To set a global projection, use the Horizontal Projection dialog.
3. Gather hydrologic data files.
  1. Gather data files for hydrologic and hydraulic data. These include data such as hydrographs, water levels, and rating curves. They will be imported when setting boundary conditions and when doing model calibration.
3. Define the project boundaries.
1. Create a new conceptual model in the Project Explorer.
Create a new conceptual model with the "FEMWATER" type.
1. Create new conceptual model.
  1. Use the New Conceptual Model right-click command in the Project Explorer.
  2. Use the Conceptual Model Properties dialog to create a new conceptual model.
2. Add coverages.
1. Create new coverage from scratch.
  1. Use the New Coverage right-click command.
  2. Use the Coverage Setup dialog to create a new coverage by selecting the desired coverage properties and naming the coverage.
2. Create new coverage from an existing coverage.
  1. Use the Duplicate command on an existing coverage. This will copy any feature objects on the coverage.
  2. Use the Rename command to give the coverage a new name.
  3. Change the coverage setup.
2. Create the boundary arcs.
1. Create feature points, arcs, nodes and vertices.
In the map module, create feature objects in the active coverage.
  1. Use the Create Arc GMS Create Arc Tool.svg tool to create arcs in the map coverage.
  2. Begin creating a new arc by clicking in the graphics window at either arc end. If clicking on an existing feature node, vertex or arc, the new arc will snap to that object.
  3. Double-click or press the Enter key to terminate the arc.
  4. Use the Create Point Create Points Tool.svg tool to create additional nodes alone or to split arcs.
2. Modify arcs.
Feature arcs, whether digitized or incorporated from a boundary condition or a material coverage, often need to be edited after initial creation.
1. Create additional vertices on arcs.
  1. Use the Create Vertex GMS Create Vertex.svg tool to add vertices along arcs.
2. Refine the arc shape.
  1. Use the Select Vertices GMS Select Vertex Tool.svg tool and the Select Points\Nodes GMS Select Node Tool.svg tool to move/edit existing arcs and refine the shape by dragging the nodes/vertices.
  2. Use the Select Arcs GMS Select Arc Tool.svg tool to move entire arcs .
3. Split arcs.
An existing arc can be split by:
1. Converting a vertex to a node.
  1. Use the Select Vertices GMS Select Vertex Tool.svg tool.
  2. Select the Feature Objects | Vertices → Nodes command to split the arc into two arcs.
2. Add a node to the arc.
  1. Use the Create Point Create Points Tool.svg tool to add a node on an arc in order to split it into two arcs.
3. Connect the end of an existing arc to the middle of the arc.
  1. Use the Select Points\Nodes GMS Select Node Tool.svg tool to drag the node of an existing arc to anywhere in the middle of another arc. This will split the second arc into two arcs.
4. Add a new connecting arc.
  1. Use the Create Arc GMS Create Arc Tool.svg tool to start or end a new arc on an existing arc to split the existing arc into two arcs.
5. Split overlapping arcs using the Clean Options dialog.
  1. Select overlapping arcs using the Select Arcs GMS Select Arc Tool.svg tool.
  2. Use the Feature Objects | Clean command to bring up the Clean Options dialog.
  3. Select the Intersect selected arcs option (for selected arcs) or Intersect arcs option (for all overlapping arcs) to split the arcs.
4. Merge arcs.
Two arcs that share an end node can be merged together.
  1. Select the shared node using the Select Points\Nodes GMS Select Node Tool.svg tool.
  2. Click on the Feature Objects | Nodes → Vertices menu command to merge the arcs.
  3. If desired, the Select Vertices GMS Select Vertex Tool.svg tool can be used to select and delete the new vertex.
5. Transform arcs.
  1. Select the arc using the Select Arcs GMS Select Arc Tool.svg tool.
  2. Use the Edit | Transform command.
  3. Use the Transform dialog to scale, translate or rotate the arc.
3. Build polygons.
Polygons are not created automatically when arcs are enclosed. To create polygons:
  1. Use the Feature Objects | Build Polygons command.
4. Define boundary conditions.
1. Assign boundary conditions to arcs.
  1. Using Select Arc GMS Select Arc Tool.svg tool, right-click on the arc and select the Attributes Table command.
  2. Define the boundary condition properties in the Attributes Table dialog.
2. Assign boundary conditions to nodes.
  1. Using the Select Point/Node GMS Select Node Tool.svg tool, right-click on the node and select the Attributes Table command.
  2. Define the boundary condition properties in the Attributes Table dialog.
5. Assign recharge values.
  1. Using the Select Polygon GMS Select Polygon Tool.svg tool, double-click on the recharge polygon.
  2. Assign recharge properties in the Attributes Table dialog.
6. Create wells.
1. Create wells points.
Create feature points in the well location.
1. Create feature points, arcs, nodes and vertices.
In the map module, create feature objects in the active coverage.
  1. Use the Create Arc GMS Create Arc Tool.svg tool to create arcs in the map coverage.
  2. Begin creating a new arc by clicking in the graphics window at either arc end. If clicking on an existing feature node, vertex or arc, the new arc will snap to that object.
  3. Double-click or press the Enter key to terminate the arc.
  4. Use the Create Point Create Points Tool.svg tool to create additional nodes alone or to split arcs.
2. Modify arcs.
Feature arcs, whether digitized or incorporated from a boundary condition or a material coverage, often need to be edited after initial creation.
1. Create additional vertices on arcs.
  1. Use the Create Vertex GMS Create Vertex.svg tool to add vertices along arcs.
2. Refine the arc shape.
  1. Use the Select Vertices GMS Select Vertex Tool.svg tool and the Select Points\Nodes GMS Select Node Tool.svg tool to move/edit existing arcs and refine the shape by dragging the nodes/vertices.
  2. Use the Select Arcs GMS Select Arc Tool.svg tool to move entire arcs .
3. Split arcs.
An existing arc can be split by:
1. Converting a vertex to a node.
  1. Use the Select Vertices GMS Select Vertex Tool.svg tool.
  2. Select the Feature Objects | Vertices → Nodes command to split the arc into two arcs.
2. Add a node to the arc.
  1. Use the Create Point Create Points Tool.svg tool to add a node on an arc in order to split it into two arcs.
3. Connect the end of an existing arc to the middle of the arc.
  1. Use the Select Points\Nodes GMS Select Node Tool.svg tool to drag the node of an existing arc to anywhere in the middle of another arc. This will split the second arc into two arcs.
4. Add a new connecting arc.
  1. Use the Create Arc GMS Create Arc Tool.svg tool to start or end a new arc on an existing arc to split the existing arc into two arcs.
5. Split overlapping arcs using the Clean Options dialog.
  1. Select overlapping arcs using the Select Arcs GMS Select Arc Tool.svg tool.
  2. Use the Feature Objects | Clean command to bring up the Clean Options dialog.
  3. Select the Intersect selected arcs option (for selected arcs) or Intersect arcs option (for all overlapping arcs) to split the arcs.
4. Merge arcs.
Two arcs that share an end node can be merged together.
  1. Select the shared node using the Select Points\Nodes GMS Select Node Tool.svg tool.
  2. Click on the Feature Objects | Nodes → Vertices menu command to merge the arcs.
  3. If desired, the Select Vertices GMS Select Vertex Tool.svg tool can be used to select and delete the new vertex.
5. Transform arcs.
  1. Select the arc using the Select Arcs GMS Select Arc Tool.svg tool.
  2. Use the Edit | Transform command.
  3. Use the Transform dialog to scale, translate or rotate the arc.
2. Add well properties.
  1. Using the Select Point/Node GMS Select Node Tool.svg tool, right-click on well nodes and select the Attributes Table command.
  2. Define the well properties in the Attributes Table dialog.
7. Define materials.
  1. Select the Edit | Materials menu command.
  2. Define materials in the Materials dialog.
8. Generate a 2D mesh.
Generate a 2D mesh to use in creating elevation zones.
  1. Select the conceptual model to make it active.
  2. Select Feature Objects | Map → 2D Mesh command.
9. Generate TINs.
1. Build TINs from 2D mesh.
Generate a TIN for each elevation zone.
  1. Select the 2D mesh.
  2. Select the Mesh | Convert to | TIN menu command.
  3. Enter TIN values in the Properties dialog.
2. Interpolate elevation data to TINs.
1. Set interpolation options
  1. Select the Interpolation | Interpolation Options menu command.
  2. In the 2D Interpolation Options dialog select the interpolation method and options.
    2D interpolation methods include the following:
2. Interpolate to a TIN.
  1. Select the target TIN in the Project Explorer to make it active.
  2. Select the Interplation | Interpolate→Active TIN menu command.
  3. Set the dataset name and review interpolation options in the Interpolate→Object dialog.
10. Generate a 3D mesh.
11. Set up the FEMWATER simulation.
1. Create a new FEMWATER simulation.
  1. Select the FEMWATER | New Simulation menu command.
  2. Enter options in the FEMWATER Run Options dialog.
2. Enter analysis options.
1. Enter run options.
  1. Select the FEMWATER | Run Options menu command.
  2. Enter options in the FEMWATER Run Options dialog.
2. Define the geometry file.
  1. Select the FEMWATER | Geometry File menu command.
  2. Enter options in the Geometry File dialog.
3. Enter titles.
  1. Select the FEMWATER | Titles menu command.
  2. Enter options in the FEMWATER Geometry and Model Title Cards dialog.
4. Set initial conditions.
  1. Select the FEMWATER | Initial Conditions menu command.
  2. Enter options in the FEMWATER Initial Conditions dialog.
5. Set iteration parameters.
  1. Select the FEMWATER | Iteration Parameters menu command.
  2. Enter options in the FEMWATER Iteration Parameters dialog.
6. Define particle tracking parameters.
  1. Select the FEMWATER | Particle Tracking menu command.
  2. Enter options in the FEMWATER Particle Tracking dialog.
7. Set time controls parameters. (For transport modeling)
  1. Select the FEMWATER | Time Control menu command.
  2. Enter options in the FEMWATER Time Control dialog.
8. Select output control.
  1. Select the FEMWATER | Output Control menu command.
  2. Enter options in the FEMWATER Output Control dialog.
9. Define fluid process.
  1. Select the FEMWATER | Fluid Properties menu command.
  2. Enter options in the FEMWATER Fluid Properties dialog.
12. Map the model.
  1. Select the conceptual model.
  2. Select Feature Objects | Map → FEMWATER.
  3. Select the appropriate options in the Map → Model dialog.
13. Define material properties.
  1. Select the Edit | Materials menu command.
  2. Enter material properties in the Materials dialog.
  3. If needed, generate unsaturated curves:
14. Run FEMWATER.
  1. Save Save Macro.svg the project.
  2. Run FEMWATER Run FEMWATER Macro.svg.
15. Visualize the solution.
1. Change display options.
1. Set display options.
  1. Open the Display Options Display Options Macro.svg dialog.
  2. Set the general display options.
  3. Set general lighting options.
  4. Set display options for each module that is being used.
  5. Set contour options.
  6. Set vector options.
2. View display.
  1. Use the Rotate Rotate Tool.svg, Pan Pan Tool.svg, and Zoom Zoom Tool Icon.svg tools.
  2. Use the View menu commands found in the Display menu.
  3. Use the Frame Frame Macro.svg command to center and resize the display as needed.
3. Adjust display.
Display may need to be adjusted during the remainder of the project.
  1. Use the Display Options dialog and viewing tools as needed.
  2. Use the Frame Frame Macro.svg command to center and resize the display as needed.
2. Change contour options.
  1. Turn on Contours in the Display Options dialog and set contour options. The "Color Fill" option is recommended for this.
  2. Look for inconsistent points (points with values much higher/lower than their neighbors or regions where no data points exist).
  3. Verify that the region being modeled is covered by the elevation/depth data and there are no holes.
3. Create a plot.
1. Start the plot wizard.
  1. Select the Display | Plot Wizard menu command.
2. Select available plot type.
1. Computed vs. Observed Data plots.
1. Computed vs. Observed Data.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Computed vs. Observed Data" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
2. Computed vs. Observed Data (Weighted).
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Computed vs. Observed Data (Weighted)" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
2. Residual vs. Observed Data plots.
1. Residual vs. Observed Data.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Residual vs. Observed" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
2. Residual vs. Observed Data (Weighted).
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Residual vs. Observed (Weighted)" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
3. Parameter Sensitivity plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Parameter Sensitivity" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
4. Error vs. Simulation plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Error vs. Simulation" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
5. Error vs. Time Step plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Error vs. Time Step" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
6. Error Summary plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Error Summary" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
7. Time Series plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Time Series" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
8. Active Dataset Time Series plot.
  1. Select a dataset in Project Explorer.
  2. Select cells in the project.
  3. Select Display | Plot Wizard to start the Plot Wizard.
  4. Select the "Active Dataset Time Series" option on the left and click Next.
  5. Specify plot options in step 2 of the Plot Wizard then click Finish.
  6. Review plot window.
9. S/S Flow vs. Time plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "S/S Flow vs. Time" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
10. Flow Budget vs. Time plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Flow Budget vs. Time" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
11. Gage Package Value vs. Time plot.
  1. Select Display | Plot Wizard to start the Plot Wizard.
  2. Select the "Gage Package Value vs. Time" option on the left and click Next.
  3. Specify plot options in step 2 of the Plot Wizard then click Finish.
  4. Review plot window.
4. Create an animation.
  1. Select a solution dataset and use the Display | Animate menu command.
  2. Use the Animation Wizard to specify the animation parameters.
  3. Save and view the animation file.